Scripts / [SOLVED] CineGuru Actors not working

Author
Message
HomeDepo410
6
Years of Service
User Offline
Joined: 18th Jan 2018
Location:
Posted: 10th Feb 2024 02:28
Everytime I test my game, just before the game loads in I get the message "LUA ERROR scriptbank\Cine Guru\cg_actor.lua:451: table index is nil"

Here's the action test for geroy

[_code]
geroy,anim_4610_4675_0.8
[_/code]

I've made sure his script is set to cg_actor.lua and his name is "geroy,Cine Guru\\geroy

The author of this post has marked a post as an answer.

Go to answer
PM
AmenMoses
GameGuru Master
8
Years of Service
User Offline
Joined: 20th Feb 2016
Location: Portsmouth, England
Posted: 10th Feb 2024 10:52 Edited at: 10th Feb 2024 10:54
This post has been marked by the post author as the answer.
Hmm, that error indicates that it is not picking up the script name properly from the actors entity name.

Try putting the geroy.txt file in scriptbank folder rather than in the Cine Guru folder and rename the actor to be "geroy,geroy" and see if that makes any difference.

Btw, do the examples work? (i.e. Bob & Jane etc)
Been there, done that, got all the T-Shirts!
PM
HomeDepo410
6
Years of Service
User Offline
Joined: 18th Jan 2018
Location:
Posted: 10th Feb 2024 16:00
Thank you so much AmenMoses, that fixed the problem for all the characters I had as well.

And the examples were having the same problem, but that fixes too when I move it to \scriptbank and rename the actors properly
PM

Login to post a reply

Server time is: 2024-02-22 03:34:46
Your offset time is: 2024-02-22 03:34:46