Scripts / [SOLVED] Simple video show script

Author
Message
Garry68
1
Years of Service
User Offline
Joined: 8th Aug 2020
Location:
Posted: 30th Aug 2020 17:31 Edited at: 5th Sep 2020 20:02
OK, so I looked through stuff and can't see whats wrong with my script, but it doesn't show the (e,1) video or play the (e,0) sound.



The g_Score is just a global variable that holds a 'percentage done' score. I want this to kick off a cut-scene
The sound and video files are set in the trigger objects properties.
Am I doing something fundamentally wrong here?


Any help would be appreciated.

The author of this post has marked a post as an answer.

Go to answer
PM
Garry68
1
Years of Service
User Offline
Joined: 8th Aug 2020
Location:
Posted: 5th Sep 2020 20:00
So I figured out that it's the 'PlayVideo(e,1)' command that isn't running the video.
If I comment that out the sound plays, but no video, but the video file plays outside of GameGuru fine.

So is there anything in particular about the video file that is compatible with GG, other than that it needs to be a WMV?

By the way, I'm trying to run this from a 'Story Zone' object. And it also doesn't work if I use the default 'storyinzone.lua' script ether, which I don't want to use as it does things I don't want.

Is there a default WMV file anywhere in the package that I can use to test this?
PM
AmenMoses
GameGuru Master
5
Years of Service
User Offline
Joined: 20th Feb 2016
Location: Portsmouth, England
Posted: 5th Sep 2020 21:10
Look in files/videobank
Been there, done that, got all the T-Shirts!
PM
Belidos
3D Media Maker
6
Years of Service
User Offline
Joined: 23rd Nov 2015
Playing: The Game
Posted: 5th Sep 2020 21:20
This post has been marked by the post author as the answer.
Your issue is your format. PlayVideo(e,1) only plays MP4, it used to play WMV prior to the DX11 update, but the DirectX11 video driver only plays MP4 so it had to be changed.

Primary Desktop:
i7 7700,k NV1070 8GB, 16GB 3200mhz memory, 1x 2TB Hybrid, Win10.

Secondary Desktop:
i5 4760k, NV960 2GB, 16GB 2333mhz memory, 1x 2TB Hybrid, Win10.

Primary Laptop:
i5, NV1050 4GB, 8GB memory, 1x 1TB HDD, Win10.

Secondary Laptop:
i3, Intel 4000 series graphics, 6GB memory, 1x 500gb HDD, Win8.1.
Garry68
1
Years of Service
User Offline
Joined: 8th Aug 2020
Location:
Posted: 6th Sep 2020 01:20
Thanks, everything I read talked about the WMV format.

I changed it to an MP4 and it worked fine.
PM

Login to post a reply

Server time is: 2022-01-25 03:59:41
Your offset time is: 2022-01-25 03:59:41