Google+

forums

Bug Reports / The latest update has broken sprites (runtime 301)

Author
Message
Avenging Eagle
12
Years of Service
User Offline
Joined: 2nd Oct 2005
Location: UK
Posted: 18th May 2017 22:02
My level won't test game anymore and after much head scratching, I've narrowed it down to a few lines in a 430 line LUA script I wrote to control global sprites like objectives, health and weapon type. Early in the script, I've written this:

+ Code Snippet

...which defines a global called 'ammotype'. The idea is that the sprite swaps out depending on what weapon you're using. However, Game Guru no longer understands that 'ammotype' has meaning, meaning it now looks for a sprite called 'ammotype'. Here's the offending extract:

+ Code Snippet

I want to stress that this worked before the 12.05 update. And before you say, yes, 'ammotype = {}' can be found in the first lines of the init (and I've tried shifting it to before the init). Goddamnit Game Guru

AE
smallg
Valued Member
11
Years of Service
User Offline
Joined: 8th Dec 2005
Location:
Posted: 19th May 2017 09:38
Its not an array so using ={} would he wrong but if it worked before then most likely the file is missing somehow?
Can you post the full script just in case?
If you don't want to share it publicly you can email it to me and I'll check it.
lua guide for GG
https://steamcommunity.com/sharedfiles/filedetails/?id=398177770
windows 10
i5 @4ghz, 8gb ram, AMD R9 200 series , directx 11

Login to post a reply

Server time is: 2017-11-20 18:48:39
Your offset time is: 2017-11-20 18:48:39